Back
Maintenance

Systemupdate v4

Completed 2 May at 09:00pm CEST.

terminmanager.net
Completed

Maintenance completed

Posted 2 May at 09:00pm CEST.
Started

We are updating der Core Software to a brand new Version!

Posted 2 May at 08:00pm CEST.